Introduction to NoteAbility Pro

NoteAbilityPro™ allows you to generate beautiful music scores quickly and accurately, to listen to your score through MIDI synthesizers or built-in audio devices, to extract instrumental parts if needed, and to print out the finished document using high precision graphics on your compatible printer. The extensive on-line help files included with the program will provide you with all the information you need to install and use this application.

Program Design

NoteAbilityPro was designed to be as natural as possible for the composer or arranger to use. It is page-oriented in design, and emphasizes flexible graphical control of music images, intelligent automation of notational syntax, WYSIWYG (What-You-See-Is-What-You-Get) display and an accessible and a direct user interface. A blank score is set up according to a template specifying page size, initial number of systems on the page, staves per system and measures per system. Using the paradigm of a composer writing on pages of manuscript, the music images are entered directly onto the page at any location and in any order. New pages are automatically added as required, and the user can freely more from one page to another either by using the measure and page controls located at the top of the score window.

The important User-Interfaces to NoteAbilityPro are outlined below:

Score Controls

The NoteAbility Score Controls are located at the top of each score window. These buttons sliders and other controls include the NoteAblityPro Tool palette (for selecting a tool to perform insertion or editing tasks), the current command display (which identifies which image will be entered in the score next), as well as page, measure, beat, staff and playback controls.

Music Images Panel

The Music Images panel normally remains visible at the top-right corner of the screen, and contains a series of segments (or panes) which are used for modifying characteristics or attributes of selected music images. Each pane in the Music Images panel contains several different views which can be selected by clicking on the tab. As well, new panes can be added and other panes removed from the panel by selecting items in the pull-down menu at the top of the panel. Each pane also contains a small pull-down menu located on the right side of the view - this menu contains items relevant to the specific pane. In the example below, the Note Attributes segment is shown in the Music Images panel.

Clicking on the Heads tab displays a pane with buttons for changing the noteheads of selected notes

The pull-down menu associated with this pane is shown below. These menu items are duplicated in the main menu - they are duplicated here for convenience.

Score Structure Panel

The Score Structure panel is normally kept visible at the bottom-right corner of the screen. Like the Music Images panel, it holds a series of panes that can be added to and removed using the pull-down menu at the top of its window. The panes of this panel are used to alter the structure of the score and to perform some complex editing procedures. Operations such as altering time signatures or key signatures, changing the number of systems per page or measures per system, hiding and showing staves within the system, and changing staff size or attributes are found in the Score Structure panel. In the example below, the Staff Attributes segment is shown. There are three different, but related panes which can be accessed by clicking on the tabs: Staff Lines, Staff Labels, and Staff Size.

NoteAbility Menus

As well as standard filing operations such as Open, New, Save, Print and Quit, NoteAbility has an extensive Edit menu (which includes several different paste commands), a Format menu for modifying document features and alignment settings, a Tools menu for performing tasks such as part extraction and setting tempo changes, a Modify menu for changing the characteristics of Notes, Beams, Tuplets and Accidentals and and Audio/Midi menu for controlling playback characteristics. NoteAbility on-line help files are located in the Help menu. These help files are indexed and searchable using the Apple Help Viewer application.

© Keith A. Hamel 1998-2005 - All Rights Reserved