Tutorial 1

The first tutorial will take you through the steps needed to create a simple 1 page composition for violin and piano. It introduces:

  1. Document Setup panel
  2. Keyboard Entry of Images
  3. Mouse Entry of Images
  4. Building Chords
  5. Simple Copy and Paste
  6. Reformating of System Layout
  7. Simple Slurs
  8. Different Staff Sizes
  9. Page Text and Measure Text
  10. Repeat Barlines
  11. Setting Tempo and DLS instruments
  12. Page Setup and Printing

The first composition is short folk song for violin and piano entitled Song of the Wind. It will be familiar to all those who have studied the Suzuki violin method. The finished composition is shown below.

Step 1: Launch NoteAbility and create a new empty document

Launch NoteAbility by double-clicking the NoteAbilityPro.app icon. Once the program has loaded, choose New from the File menu. In the Document Setup panel that appears on the screen, alter the following settings by adjusting the sliders and setting radio buttons:

Once the Document Setup panel looks the same as the example above, click on the Create Document button.

A blank score should appear with the format you just specified. If the format is incorrect, close the document by clicking on the close button (red button in the top-left corner of the window), choose New once again from the File menu and try again.

When the layout looks correct, choose Save from the File menu to give the score a name and to save it onto your hard drive in a convenient location. While you are working on the score, it is recommended that you save the document periodically by selecting the Save menu or typing Command-s. You can play back the score at any time while you are working through the tutorial by clicking on the Play button at the top of the score window.

Step 2: Enter the Violin Part using the On-screen Keyboard.

If you are familiar with the piano keyboard, choose Keyboard... from the Tools menu to bring up the Keyboard panel. If you prefer not to use the Keyboard panel, then you can enter notes by clicking the mouse at the correct pitch position close to the Entry Cursor. While enteing images, you should make sure that the Insertion tool is selected in the NoteAbilityPro Tool palette at the top of the score. As you enter notes, the Entry Cursor will increment to the next beat location. If you make a mistake, choose Undo from the File menu (or type Command-z) to remove the last note. If necessary, you can select incorrect notes (with the Selection tool ) and delete them or select them and drag them to a change their pitch. If you need to adjust the position of the Entry Cursor while you are entering notes, you can either use Spacebar or Shift-Spacebar to move the Entry Cursor, or you can drag it to a new location by grabbing the rectangular area on the right of the Entry Cursor. Remember that the Insertion tool must be selected in the NoteAbilityPro Tool palette (located at the top of the score window) while you are entering notes.

Since the top line of the music starts with eighth notes, type e on your typewriter keyboard so that the program will enter eighth notes. On the on-screen keyboard, locate middle C (C3) - it is slightly shaded, and click the first few notes of the piece on the on-screen keyboard (A3, B3, C#4, D4, E4, E4, E4, E4, F#4, D4, A4, F#4).

- When refering to notes in this tutorial, the convention of naming notes along with their octave is used. Octaves run from C to B, with middle C being octave 3. Thus, middle C is refered to as "C3", the B below middle C is "B2", and the top line of the treble clef is F4.

The Entry Cursor should now be located at the beginning of measure 3. Since the next note is a quarter note, type q on the typewriter keyboard and click on (E3) on the on-screen keyboard. To enter a quarter rest, you can either change the command to rq and click the mouse close to the Entry Cursor, or (as a short-cut) you can type Command-r while keeping your Command as q. The Entry Cursor should now be located at the beginning of the fourth measure. Change the Command between e, q, and rq and continue entering the correct pitches and rests until you have reached the last measure of the piece.

- When you are more familiar with NoteAbilityPro, you will probably used the Copy and Paste procedures for the repeated passages in this melody.

The score should now look something like this:

Step 3: Enter the Piano Part using the Copy/Paste and Mouse Entry.

You will notice that the right hand of the piano part is almost identical to the violin part - this is a good opportunity for Copy and Paste.

Choose the Selection tool (arrow icon) from the NoteAbilityPro Tools. When you move the mouse cursor back onto the score, the cursor should be an arrow. Drag a rectangle so that it includes all the notes in the violin part. (Start at the top right corner of the score and drag the mouse to the bottom-left corner of the score.) Later on, you will learn that you can also use the Selection tool to Shift-Select multiple rectangles or you can select portions of the score with Select-Score tool. The images within the rectangle are displayed in a different colour to indicate that they are selected. Choose Copy from the Edit menu or type Command-c. The images have now been loaded into memory are ready to be pasted into the score. Images are pasted beginning at the position of the Entry Cursor, so before we paste, we must position the Entry Cursor on the first beat position in the first measure of the piano right hand staff (i.e. the second staff in our system.) Move the Entry Cursor by dragging the rectangle on the right side of Entry Cursor. The beat location will appear inside the Entry Cursor, so you will know when you at beat 1.0. Once the Entry Cursor is in the correct location, choose Paste Into from the Edit menu (or type Command-v). The copied music should appear on the top staff of the piano part.

There are some additional notes that need to be entered in the piano part (eg. 4-C#4 eighth notes in measure 2, an F#4 and a D4 in the second half of measure 3 and the second half of measure 5, and a C#3 in measure 14. Type e so it appears in the Command field, and move the Entry Cursor to the beginning of measure 2. You can move the Entry Cursor by depressing the Spacebar or by dragging the Entry Cursor as you did earlier. Once you are at the correct measure and beat location, click the mouse near the Entry Cursor at the C#4 pitch level. While you hold the mouse down, you can move the note up or down. Release the mouse when you see the correct pitch displayed. Continue entering these additional pitches in measures, 2, 3, 5, and 14. (Remember to change the Command to q before entering the C#3 quarter note in measure 14.

You can enter the piano left hand with either entry method (on-screen keyboard or directly with the mouse. In order to build chords, you can move the Entry Cursor back by clicking on the small back arrow located on the Entry Cursor or you can click on the Go Back button on the Keyboard panel or you can type Command-g. Remember to change the Command from q to e as needed. Notice that the last measure contains an eighth rest - the command for an eighth rest is re.

Once you have entered all the notes for the piano part, the score should look something like this:

Step 4: Adjust the Page Layout

Although there are still a few images to enter (dynamic markings, text, slurs, down bow marks), it is usually better to set your final page layout before adding these images. Lets adjust the layout now. Since we want the first system indented slightly, lets have only 4 measures in that system. To change the number of measures in the system, click on the small arrow with a minus sign on it located to the right of the top staff on the page. This will reduce the number of measures on that system, passing the extra measure to the next system, which in turn passes its extra measure to the third system.

- it is also possible to change the number of measures in a system by using the controls on the Measure In System pane in the Score Structure panel.

The final barline of the composition is a repeat barline, so you should position the Entry Cursor in this measure and locate the Barline & Braces pane from the pull-down menu in the Score Structure panel.

- if the Score Structure panel is not visible, you can show this panel by selecting Score Structure Panel... from the Tools menu. If the Barlines & Braces pane is not available in the Score Structure panel, you can choose it from the Available Panes pull-down menu at the top of the Score Structure panel.

Click on the Repeat-End barline in this panel (the first button in the second row of barline types.) The radio buttons should be set as in the example above. The barline should now be changed in your score.

You might also want to adjust the distances between two piano staves in your score. This can be done several different ways in NoteAbilityPro, but we will start with the simpliest and most direct way. You can manually adjust the position of the second piano staff (in each system) by grabbing and dragging (in an upward direction) the button which is at the right edge of the bottom staff line. As you drag the staff, the position of the images on this staff will adjust. Move the bottom staff closer to the staff above in each of the three system

Your formatted score should now look like this:

Step 5: Add Additional Images and Text

There are a few images that now need to be added to the score. There are two 'mf' symbols at the beginning of the score, some slurs, some down bow signs and some text.

First, add the 'mf' symbols by typing mf (which should appear as the Command in the Score Controls). Make sure the Insert tool is selected in the NoteAbilityPro Tool palette and move the mouse cursor (which has a target icon) to the location you want the first 'mf' to appear (below the first measure of the violin staff) and click on the mouse button. While the mouse button is depressed, you can drag the mf symbol until you have placed it exactly where you want it. Add a second 'mf' symbol between the two staves of the piano (in measure 1). Since the Command is already 'mf' you can just click the mouse in the new location to add the second image. If you are not happy with the position of these symbols, choose the Selection tool from the NoteAbilityPro tools, make a rectangle around the symbol, place your mouse cursor inside the rectangle and drag the image to a new location.

Next, add the down bow signs which appear above the violin part in measures 1, 5, 7, and 11. The Command for a downbow is 'db'. Type this command and click the mouse cursor at the desired location (as you did with the 'mf' symbols). You should take care not to click your mouse directly on the Beat Markers (since NoteAbilityPro will think you are trying to adjust the beat location). However, once the downbow sign appears on the screen, you may move it (while the mouse button is down) on top of the Beat Marker or any where else on the page you would like it to appear. You can enter all four down bow symbols without changing the Command.

There are several ways to enter slurs, but the simpliest method is to select the group of notes to be slurred and click on the Slur Notes button. To select the notes to be slurred, use the Select tool in the NoteAbilityPro Tool palette and drag a rectangle around the four notes in the fourth measure of the second staff of the piano. These notes should change colour to indicate that they are selected. Click on the Slur Notes button located located in the top-right corner of the Score window or type the shortcut Command-Shift-w.

Repeat this procedure with the four notes in the sixth measure of the second staff of the piano. The start, end and middle points of these slurs can be adjusted if desired. To adjust them, grab one of these points (with the Selection tool chosen) and drag the point to adjust the shape of the slur.

There are actually four different types of text in NoteAbility, but for now we will only ook at two. The first type of text is Page Text which is fixed at a location on the score page. This type of text is used for titles, copyright notices, and any other text that is not part of the musical score. To enter the title of this composition, choose the Page Text tool from the NoteAbilityPro Tool palette and click the mouse at the location on the page that you would like the title to start. An I-beam cursor should appear at this location, and you may now type in the title. If you want to change the size or font, select the characters (still using the Page text tool) and bring up the Font panel (Command-t) from the Font menu. You can adjust the location of the title by choosing the Selection tool, clicking the mouse somewhere in the body of the text and dragging the text to the new location. The second type of text we need to enter is called Measure Text. This type of text is considered to be part of the music and will adjust as the music around it is adjusted. Choose the Measure Text tool in the NoteAbilityPro Tool palette and click the mouse cursor above the first measure of the composition. Type "Moderato q = 84". Select the text and change the font by bringing up the Font panel from the Font menu and choosing a new font. Select the "q" in the text and change it to a music font (such as Scriabin6) by finding this font in the Font panel. (A "q" in a music font will appear as a quarter note.) As before, you can adjust the location of your text by dragging it with the Selection tool.

Now that all the notes and other images have been entered into the score, it should appear as below:

Step 6: Change the Size of the Violin Staff

As the final editing step, we want to make the violin staff slightly smaller than the piano staves. To do this, move the Entry Cursor to the first measure of the piece, and locate the Staff Attributes pane in the Score Structure Panel and click on the Size tab to display the controls of changing staff sizes.

- if the Score Structure panel is not visible, you can show this panel by selecting Score Structure Panel... from the Tools menu. If the Staff Attributes pane (which has tabs labeled Staff Lines, Labels, and Size) is not available in the Score Structure panel, you can choose it from the Available Panes pull-down menu at the top of the Score Structure panel.

Make sure the Staff ID display shows 1 (since it is the first staff in the system we want to modify). Adjust the Staff Size slider until the display shows 18. (Since 24 points is the default image size, 18 points is about 75% of the original size). Since we want the entire violin part to be adjusted, make sure the All Subsequent Systems radio button is selected. Click on the Change Staff Size button.

Congratulations, you score is now completed, and should appear similar to the one below:

Step 7: Add Playback Settings

Although not a necessary step in creating and printing the score, you might like to have a more realistic performance of this score. To achieve this, we must set the tempo, the playback map (i.e. which measures are repeated), and the DLS synthesizer or MIDI instruments to be used.

To set the tempo, adjust the tempo slider in the Playback Controls pane of the Music Images panel so that the tempo field displays 84. This will be the fixed tempo for the composition. Later on, you can learn how to create tempo changes during playback.

To set the composition to repeat (since there is a repeat sign at the end of the measure 14), choose Playback Map from the Tools menu. In the Playback Map panel, enter the values 1, 14, 1, 14 in the respective start and end fields (as shown below).

To set the DLS Synthesizer Instruments (or MIDI channels) for playback, Choose Track Setup... from the Audio-MIDI menu. In the Track Setup panel, you can set the patch number for DLS, Quicktime or MIDI playback. The General Midi patch for violin is 41 and for piano is 1. Set staff 1 to use Patch 41, and set staves 2 and 3 to use Patch 1. If you would like to choose a different DLS instrument, click on the DLS button for each of the staves, and a list of all available instruments will appear. Once set, the top of the Track Setup panel should look similar to the example below:

Once you have set the patches, click on the Done button in order to close the panel. You can now play your score by clicking on the Play button in the Score Controls at the top of the score window or by clicking on the Play button in the Playback Controls pane in the Music Images panel.


Play Complete Score -- Play From Entry Cursor

The correct tempo, correct patches and the repeats should all be audible now.

Step 8: Print the Score

Since this score fits nicely on a standard page size at the 90% reduction size you set up when you created the document, it is probably not necessary to alter these settings. If you would like to do so anyway, choose Page Setup... from the File menu. In the pull-down menu in the Page Setup panel, select NoteAbilityPro to show the NoteAbility Page Setup options. Choose the paper type, orientation, printing scale, etc., and click the OK button when you are done. To print the score, choose Print from the File menu. If you have a compatible printer connected to your computer, the score should now print.

Congratuation, you have completed the first tutorial. Save your composition, and when you are ready, begin working on a new composition, or work through Tutorial 2.

See also

© Keith A. Hamel 1998-2009 - All Rights Reserved