Tutorial 2

The second tutorial will take you through the steps needed to create a moderately complex composition for voice and piano - Mädchenlied by Johannes Brahms

In addition to the features you have already learned, Tutorial 2 introduces:

Since the complete composition is about 45 measures long, the tutorial will focus on the first page of the score. You may complete the remainder of the piece on your own - a copy of the completed composition can be found in the NoteAbilityExamples folder (in the /Library/Application Support/NoteAbilityPro folder).

The completed first page of the composition should look as follows:

- Remember to save periodically as you work through the tutorial.

Step 1: Set up the score format.

As before, the first step is to create the basic score layout. Mädchenlied is a song in 3/8 time in the key of A minor (no sharps or flats). Choose New from the NoteAbilityPro File menu, and in the Document Setup panel, set the following values:

Other settings can be left at their default settings. Remember to hit return after entering new values in the editable fields in this panel, so that the miniature score page is updated with the correct values.

Since we want to add staff labels to this score, click on the Custom System button, and enter "Voice" as the first Main label, and "Piano" as the second Secondary label (which will cause the label to be centred between staves 2 and 3). Set the clefs to: staff 1 - treble, staff 2 - treble, staff 3 - bass. Enter "2" and "3" in the first two fields of the Brace list and click on the button below the piano brace icon (to have a piano brace drawn between staves 2 and 3, and enter "1", "1", "2", and "3" in the first four fields of the Barline list (to have barlines drawn on staff 1 and between staves 2 and 3.) Click on the Done button.

You should again see the Document Setup panel. Notice that the Brace and Barline settings have switched to Custom since we are now using the information entered in the Custom System panel.

Click on the Create Document button and a blank score should appear. If the document does not look correct (i.e. there are missing staves, braces, or barlines) choose New again from the File menu and check that all the correct values have been entered,

Since this score has an pickup measure at the beginning, we should first create this partial measure. To create partial measures, we must first understand that NoteAbilityPro counts every bar and partial bar as if it were a complete measure. We can exclude the partial measures from being counted with measure numbers if we want to, but internally, the program still counts all measures (partial or complete) from the beginning. To create a 1/8 pickup (or upbeat) measure, check that the Entry Cursor is in measure 1 and select the Partial MM tab from the Time Signature pane in the Score Structure panel.

- if the Score Structure panel is not visible, you can show this panel by selecting Score Structure Panel... from the Tools menu. If the Time Signature pane is not available in the Score Structure panel, you can choose it from the Available Panes pull-down menu at the top of the Score Structure panel.

Set the meter sliders so that 1/8 is indicated, check that Exclude this from Measure Count is selected, and Click on the Create Partial Measure button. You should notice that measure 1 only has 1 beat button in it and that the measure numbers on the score have been adjusted.

- Notice that the Measure Number display at the top of the score window shows both the structural measure number and the notated measure number. The first full measure of the composition structurally is measure 2, but numerically is measure number 1.

Step 2: Enter the Notes in the Voice Part

You can enter notes either with the mouse and/or with the on-screen Keyboard. Remember to enter the correct rhythmic value before adding the note. The rhythmic value can be indicated by typing a letter (q, e, s, etc) or by selecting the note value from the Note palette along the top of the score window.

Notice that portions of the voice and piano parts have two voices on the same staff.

- In NoteAbility a voice is considered to be a note or chord on a separate stem. Normally, there are three voices allowed on each staff. The first voice has stems which go either up or down depending on the pitches, the second voice has stems that go up, and the third voice has stems that go down.

In places where there is only one voice on the staff, use Voice 1. Where there are 2, enter the second voice either in Voice 2 (stems up) or in Voice 3 (stems down). The voice number is set with the radio buttons in the Score Controls at the top of the score window.

In order to simply adding lyrics, we should enter most of the vocal part in Voice 1, and only switch to Voice 2 or Voice 3 when necessary. Also, since the voice part in this edition uses the convention of not beaming notes unless they are sung to the same syllable, we should temporarily turn Auto-Beaming off. To do this, choose the Preferences menu item from the NoteAbilityPro menu, and uncheck the Auto Beam On button in the Formatting tab of the Preferences panel. Close the panel when you are done.

Two keyboard shortcuts that we will useful while entering the voice part are:

-If you enter the wrong pitch, use the up and down arrow keys on your typewriter keyboard to adjust the pitch.

The first measure of the voice part has two voices (both on the same pitches). With the Insertion tool selected type s to indicate that a sixteenth note will be entered and click the mouse so that the notes A3 and B3 are entered. With auto-beaming turned off, these notes should appear with flags on them. Drag the Entry Cursor (or type Shift-Spacebar) to return the Entry Cursor to the beginning of the score and select the Voice 3 radio button (stems down). Enter the notes A3 and B3 again. The note heads of these new notes will be aligned with the previous notes, but the stems will be drawn in a downward direction. Switch to the Selection tool , make a rectangle around the stems/flags of these notes, and type command-b to beam the notes.

Switch back to the Insertion tool, select Voice 1 (stems both direction), type e to change the Command (since we want to add some eighth notes), and enter the next 5 notes. C4, B4, A4, G#4, A4. After the G has been entered, type Command-3 or click on the Sharp button on the Toolbar to add a sharp to the G. Enter the last beat of this measure as follows:

  1. type s to set the Command, and enter the note B3.
  2. type command-f to flip the stem of this note so it is drawn in a downward direction
  3. Enter C4.
  4. Drag the Entry Cursor back to the third beat of this measure and switch the Voice to 2 (stems up).
  5. Enter the notes B3 and C4 again.
  6. Switch to the Selection tool and select the stems of these notes (i.e. the ones with the stems in an upward direction) and type command-b to beam these notes.

The first three measures should look as follows:

The fifth measure (mm. 4) has two different rhythms in the two voices, but the procedure is the same. Enter Voice 2, (eighth notes A3 and B3, sixteenth notes C4 and D4). Select the last two notes (using the Selection tool and choose the Beam Notes item from the Modify/Beams (Command-b) or click on the Beam Notes button in the Score Controls. The last two sixteenth notes will be beamed and the measure should looks as follows:

Move the Entry Cursor back to the beginning of this measure and enter Voice 3 (dotted eighth note A3, sixteenth notes B3 C4 D4) To enter the dotted eighth, use the command e. or click on both the eighth note button and the dot button in the Note palette above the score. Here, two beam groups have to be created. Select the first two notes using with the Selection tool. Since the noteheads of both voices are in the same locations, select these notes by dragging a rectangle around the bottom of the stems. Use the Beam Notes menu item (command-b), then select the last two notes in this measure (select the stems of these notes for the same reason) and beam these notes as well. This finished measure should look like this:

Complete the remainder of the voice part; there are no more beamed groups in the voice part on the first page. To enter the rests (beginning on the third beat of Measure 10 (mm.9), type the command rewwee - this will enter the series of rests. If you have scrolled to page 2, return to page 1 by clicking on the left page arrow on the Score Controls at the top of the score window. In order to have all of this music on one page, click on the + arrow located to the right of the last system on the page -- this will increase the number of measures in that system.

The score should now look as follows:

Step 3: Enter the Lyrics

To Enter the lyrics, choose the Lyric tool from the NoteAbilityPro Tools (located along the top of the score window). Move the Entry Cursor to the beginning of the score (on the top staff) and type each syllable of the first verse. Type return after each syllable. Because of the changing voices in this part, the Entry Cursor may not always move to the correct place for the next syllable. Adjust it with the mouse if it is not properly aligned. To join syllables with a dash, add a dash "-"at the end of the syllable. To add an underscore after a syllable, add an underscore "_" at the end of the syllable.

Enter the following syllables with a return after each:

Auf die Nacht in der Spinn- stub'n da_ sin- gen die Mäd- chen da_ la- chen die Dorf- bub'n wie flink geh'n die Räd- chen!

- the "ä" is created using option-u followed by a.

To move the vertical position of the lyrics, show the Preferences panel (under the NoteAbilityPro menu) and check the box beside Lyric Buttons, in the Format tab. The lyric buttons will appear on your score and you can drag these buttons down so that the lyrics are not colliding with the notes.

To enter the second verse, show the Lyrics Pane in the Music Images panel and set the verse field to 2.

Beginning in the first measure, enter the second verse lyrics:

Spinnt Je- des am Braut- schatz, dass der Lieb- ste sich freut._ Nicht_ lan- ge, so gibt es ein Hoch- zeit- ge- läut._

The score should now look as follows:

Step 3: Enter the Piano Notes and Rests

The piano part now needs to be entered. Use either the on-screen keyboard or the mouse, moving the Entry Cursor back to create chords as needed. The majority of the piano part is straight-forward, but there are a several measures (2, 4, 6, 7, and 8) which have beaming across staves, and we should look at that process more carefully. Enter the main line of the piano part for the first two measures. Remember to position the Entry Cursor on the correct staff - you can click on the up and down arrows at the top and bottom of the Entry Cursor to move it up or down within the system.

To beam the notes in the second measure, switch to the Selection tool (arrow icon) and make a rectangle around these notes:

Choose Beam Notes (from the menu or Toolbar button), and the notes will be beamed.

Adjust the vertical position of the beam by grabbing the control point just to the left of the beam. With this control point selected (either by clicking on it and making a rectangle around it), drag the beam down so that the beam appears between the two staves:

- If you would like to see where the control points for all images are, select the Show Control Points item in the Format menu. You may turn them off by using the same menu item.

Once the beam has been added, you can add the missing notes and rests, and continue adding the remainder of the notes. Notice that in certain measures there are two voices, and you should remember to switch to Voice 2 (stems up) or Voice 3 (stems down) for these passages. The first 9 measures of the piano part can now be entered.

- If you need to adjust the angle of the beam at any time, you can adjust the control point at the right side of the beam (just to the left of the last stem).

The chord in Measure 10 (mm.9) includes two cautionary G-naturals. Since these are not absolutely necessary, the naturals will not appear automatically. Select the noteheads of these two notes (G3 and G4) using the Selection tool - you can shift-select both noteheads if you want to, or select them one at a time. Once the noteheads are selected, click on the Show Cautionary button in the Accidentals & Articulations pane of the Music Images panel. The completed measure should appear as follows:

At the end of Measure 11 (mm.10) there is a clef change in the piano right hand. Place the Entry Cursor on this staff on the first beat position (1.00) of the following measure. In the Clef & Key Signature pane of the Score Structure panel, adjust the slider until a bass clef is displayed, and click on the Insert Clef button.

A bass clef will be inserted, and the measure should look as follows:

Continue entering the piano part for the last two measures. The 8va basso in Measure 12 is entered using the Octava tool from the NoteAbilityPro Tools. This tool is used for drawing both 8va and 8vb (octava basso) symbols. To draw an 8vb symbol with this tool, hold down the shift key while you drag the mouse from left to right below the notes. You do not have to position the Entry Cursor when entering images of this kind. The result should look something like this:

- if you would like the score playback to be accurate, you should select the four notes in the bass clef (above the 8vb sign) and go to the Transpose tab in the Transpose/Shift Images pane in the Score Structure panel. Set the transposition interval to be Down a Perfect 8ve and click on the Alter Playback Only button. These notes will be transposed down an octave when played.

Measure 13 (mm.12) is a partial measure - a 2/8 measure with a repeat sign at the end. With the Entry Cursor in this measure, use the Partial MM tab in the Time Signature pane in the Score Structure panel. Set the sliders in this pane to 2/8 and uncheck the Exclude this Measure from Measure Count box. Click on the Create Partial Measure button in order to set this measure to have only 2 beats.

Use the Barline tab in the Barline & Brace pane of the Score Structure panel to add a Repeat barline at the end of this measure - click on the Repeat-End barline type to change the barline in this measure. All notes and rests should now be entered in the score.

Step 4: Adjust the Page Layout

Now that the basic music has been entered, you might want to adjust the positions of the staves and/or systems. To do this, move the blue arrows located at the bottom-left corners of the staves or at the top-left corners of the system. For example, in order to give more space for the lyrics, you might want to move the first piano staff down slightly. You may find that slight adjustments to the beam angles are also necessary after you move the staves. As before, to adjust the height of the beam, adjust the left control point and to adjust the angle adjust the right control point.

To indent the first system slightly, drag the System Horizontal button of the top system to the right.

Step 5: Add Slurs and Articulations

There are staccato marks above the eighth notes in Measure 10 and 12 (mm. 9 and 11). Select these notes (using the Selection tool) and click on the Articulation tab of the Accidentals & Articulation pane in the Music Images Panel.

Set the Location to the third button (articulation marks always above) and click on the staccato button. Staccato articulations will be added above all the selected notes.

Slurs can either be added by manually drawing them or by selecting groups of notes and having slurs automatically added to the selected notes. In instances where you want the slur to appear in the normal or default location, you can use the second method; select the notes you want the slur to encompass, and click on the Slur Notes button in the Score Controls at the top of the score window (or use the Hot Button shortcut - Command-Spacebar). For example, the slur in mm.1 - 2 and many of the slurs in the piano part can be done this way:

For the slur that crosses from one system to another in the piano part (measures 3 - 5), you must use the Select-Score tool and indicate the starting and ending points of the slur. Click the mouse just before the first note in the slur group (on the top piano staff) and just after the last note to be slurred (on the bottom piano staff). The selection:

will produce a slur that is broken across two systems:

Slurs that are drawn in non-standard locations (i.e. above or below beams rather than between noteheads) must be drawn freehand (as graphic slurs). This is the case for some of the slurs in the vocal part and a couple of the slurs in the piano part (top staff -- mm.9 & 11): To draw slurs freehand, select the Slur tool from the NoteAbility Tool palette. Hold down the mouse button at the location you want the slur to begin, and (with the mouse button still down) move the mouse to the midpoint of the slur. Now, release the mouse button, and continue moving the mouse to the end position of the slur. When you arrive at the end of the slur, click the mouse button once again to indicate that you have finished drawing the slur. It may take you a few attempts before you get familiar with this entry method, but very soon you will be drawing slurs quickly and accurately. Some examples of freehand slurs and where they are drawn are shown below:

Step 6: Add Text and Other Images

There is some text on this document - a tempo indication at the beginning of the score "Leise bewegt (with gentle motion)", and a "dolce" indication in the piano part in Measure 9. These texts should be entered using the Measure Text tool . After selecting this tool, click the mouse at the location you want the text to begin an type the text. Select the text you have just entered and choose the Font/Show Font Panel... menu item to change the font size, face or style. The title of the composition and the composers name should be entered using Page Text since we want these texts to be fixed at specfic locations on the page, and they should not move as the music is formatted.

With the Page Text tool selected, click the mouse at the top of the page and type the title "Mädchenlied". Once this text has been entered, select the text and centre it using the Font/Text/Center menu item, and choose the desired fonts and sizes. You can adjust the position of the text by dragging it with the Selection tool. Enter "Johannes Brahms" in another text box just above the right corner of the music. Again, select the text once it has been entered, and choose a font using the Font/Show Font Panel... menu item.

There are only a couple more markings to be added: a piano dynamic mark in the piano part (Measure 1) - command p and breath commas - command , which appear above the voice part in Measures 5 and 7 (mm.4 and 6). In both of these cases, you do not need to move the Entry Cursor since these images are neither notes nor rests. Just click the mouse at the desired location, and adjust the position of the image while the mouse button is down.

Finally, we should move the page number so that it is centred at the bottom of the page. To do this, choose the Page Num. tab in the Measure/Page Numbers pane in the Score Structure panel. Check the Centred at Bottom button, and click on the Set Page Numbers button.

The finished score should look as follows:

Step 8: Alter the Page Setup and Print the Score

Since this score was setup to be larger than the standard US Letter or A4 size, you will need to reduce it in order for it to fit on this paper size. NoteAbility will already have calculated a reduction size for you, but you may want to alter it. Choose Page Setup... from the File menu. In the panel that appears, use the pull-down menu on this panel to show the NoteAbilityPro page setup controls. You can adjust the reduction slider and/or alter the orientation of the print job.

Click OK when you done. Now, choose Print from the File menu and print the score on your printer.

Congratulations, you have completed Tutorial 2. Save the score, and feel free to refer to other chapters of this manual to see more of the many features available to you in NoteAbilityPro.

See also

© Keith A. Hamel 1998-2009 - All Rights Reserved